Service Disruption Partial Outage Resolved

Started UTC • resolved UTC • Duration

  • Investigating

    What happened

    Between 00:19 and 00:25 UTC, statuspage.me and all hosted status pages (*.statuspage.me, *.hostedstatus.page, *.sp.fyi) might have been inaccessible at some regions. The disruption was caused by an external attack that overwhelmed our web server, saturating CPU resources and preventing legitimate traffic from being served.

    Uptime monitoring was not affected; checks continued running normally throughout the incident.

    Resolution

    The service was restored at 00:25 UTC. We have since deployed mitigations to rate-limit and reject malicious traffic earlier, significantly reducing the impact of similar attacks in the future.

    What we're doing to prevent recurrence

    • Tightened server-level rate limiting on TLS connection handling
    • Reduced unnecessary logging overhead that amplified CPU impact during the attack
    • Added OS-level connection rate limiting per source IP

    We apologize for the disruption. If you have any questions, please reach out at hey@statuspage.me.

  • Resolved Latest

    This incident has been resolved. statuspage.me and all hosted status pages are fully operational.

    Uptime monitoring was not affected at any point during this incident — checks continued running normally throughout.

    We have deployed mitigations to prevent recurrence and will continue monitoring for any follow-up activity. We apologize for the disruption.