Let's Encrypt maintenance affecting new SSL certificate issuance for status pages (Status Pages) Degraded Performance Resolved

Status PagesStarted UTC • resolved UTC • Duration

  • Investigating

    Let's Encrypt (our primary SSL certificate provider) is currently down for maintenance. This is preventing automatic SSL certificate issuance for new custom domains and newly created status page subdomains.
    Existing status pages are unaffected; all previously issued Let's Encrypt certificates remain valid and are being served normally.

  • Identified

    Root cause identified: Let's Encrypt is experiencing a service-wide maintenance window affecting ACME certificate issuance. We've confirmed this via their status page (https://letsencrypt.status.io).

    What we've done:
    - ZeroSSL has been activated as our fallback certificate provider
    - New status pages and custom domains will receive valid SSL certificates automatically via ZeroSSL
    - This process takes approximately 3–5 minutes instead of the usual few seconds

    Current impact:
    - ✅ All existing status pages continue to work normally
    - ⚠️ Newly created status pages may show an SSL error for up to 5 minutes before resolving automatically
    - ⚠️ New custom domains may show an SSL error for up to 5 minutes before resolving automatically

    What to do if affected:
    If you just created a status page and see an SSL error, simply wait 3-5 minutes and refresh. No manual action is required; the certificate is being issued in the background.

    Next update: We will update this incident when Let's Encrypt returns to normal operations or if there are any changes to the expected recovery time.

  • Monitoring

    Let's Encrypt has resumed certificate issuance. We're monitoring new SSL provisioning to confirm full recovery.

    What we've done:
    - ✅ ZeroSSL fallback activated for redundancy
    - ✅ New status pages and custom domains are receiving certificates normally

    Current impact:

    Existing status pages✅ Working normally
    New status pages / custom domains✅ Working normally (via ZeroSSL during LE outage)
  • Resolved Latest

    Let's Encrypt has resumed normal certificate issuance. All status pages and custom domains are now receiving SSL certificates successfully.

    What happened:
    - Let's Encrypt experienced an outage affecting new certificate issuance
    - ZeroSSL fallback was automatically activated for all new certificates
    - No service interruption occurred for existing status pages

    Current status:
    - ✅ Existing status pages: Working normally
    - ✅ New status pages / custom domains: Certificates issuing normally via Let's Encrypt
    - ✅ ZeroSSL: Remains active as permanent fallback