Incident Details

Let's Encrypt Quick Maintenance [10min] Operational Resolved

Started UTC • resolved UTC • Duration

  • Investigating

    Let’s Encrypt is currently performing a brief database maintenance operation. Consequently, the issuance of SSL certificates may be delayed for up to 10 minutes. Nevertheless, our ZeroSSL fallback mechanism will activate in such situations, ensuring minimal disruptions.

  • Resolved Latest

    The maintenance is completed, and there were no issues or disruptions on our end.